Main Page » Getting Started » Integrating Eclipse

Integrating Eclipse

This tutorial describes how to access BaseX from Eclipse via the oXygen XML Editor plugin.

The plugin offers the same features as specified in Integrating oXygen. However, the way to get there from within Eclipse is a bit different.

Another article describes how to compile and run the BaseX sources in Eclipse.

We encourage you to use the XML editor integrated into the BaseX GUI to edit and query your XML data.

Preparations

  1. Download and install Eclipse. Note: The plugin officially supports Eclipse 4.5 to 4.39. Please also note that you will require an oXygen license to use the plugin.
  2. Follow the instructions in the oXygen Manual to install the plugin, e.g. via Help → Install New Software and the update site https://www.oxygenxml.com/InstData/Editor/Eclipse/site.xml.
  3. In Eclipse, click on the oXygen icon in the upper right corner to open the plugin. The XML Project you created during the installation of the plugin should be displayed in the Navigator panel. In this example, it is called BaseXProject:

Configuration

Added: Instructions for accessing database resources via WebDAV were re-added.

Database resources are accessed and queries are performed as described in Access Database Resources and Perform Queries. If you have already integrated BaseX into the oXygen XML Editor itself, your data sources, connections and transformation scenarios will already be available in the plugin. Otherwise, the following steps differ in Eclipse:

  • The data sources and connections are configured via menu Window → Preferences (Eclipse → Settings on macOS): In the dialog, choose the oXygen XML Editor item, and then the Data Sources subitem.

  • After a connection has been configured, click Apply and Close to close the preferences dialog. If prompted, restart Eclipse to activate all changes.


  • WebDAV write locks can be requested via Preferences → oXygen XML Editor → Network Connection Settings → HTTP(S)/WebDAV → Lock WebDAV files on open.
  • Before configuring a transformation scenario, select File → New → XQuery File, enter a filename, click Finish, enter a query and save the file. The Transformation Scenarios panel is located on the right-hand side.

Changelog

Version 13.0
  • Added: Instructions for accessing database resources via WebDAV were re-added.

⚡Generated with XQuery